MessageSDKFramework: file was built for unsupported file format

Hello, I tried to integrate your MessageSDKFramework followed by steps in "Environment Setup" section on docs.cloudchat.com, but got following error while compiling for generic iOS device (and Simulator and iPhone 7): ld: warning: ignoring file /Users/hacknick/Documents/Developer/DaMi_iOS/MyCallsheet/MessageSDKFramework.framework/MessageSDKFramework, file was built for unsupported file format ( 0x56 0x65 0x72 0x73 0x69 0x6F 0x6E 0x73 0x2F 0x43 0x75 0x72 0x72 0x65 0x6E 0x74 ) which is not the architecture being linked (armv7): /Users/hacknick/Documents/Developer/DaMi_iOS/MyCallsheet/MessageSDKFramework.framework/MessageSDKFramework Also this in "Copy Swift libraries step": warning: /Users/hacknick/Documents/Developer/DaMi_iOS/MyCallsheet/MessageSDKFramework.framework/Versions/Current: Failed to parse Mach-O: Reached end of file while looking for: uint32_t. I tried to delete / add again and download again from the web and add again - no luck. Xcode version: 9.2 (9C40b)

Comments

  • Solved! For those of you, who will struggle with this problem: I took framework from sample app, iOS folder (not legacy iOS) and removed -load_all linker flag and it seems to start working.

Leave a Comment