Cant archive: /<module-includes>:1:1: Umbrella header for module 'CometChatPro' does not include header 'XMPPAttentionModule.h'

I followed the iOS guide and can build locally to my phone, however when I archive build to submit to the app store I get dozens of errors like this:

/:1:1: Umbrella header for module ‘CometChatPro’ does not include header ‘XMPPAttentionModule.h’

/:1:1: Umbrella header for module ‘CometChatPro’ does not include header ‘XMPPMessage+XEP_0066.h’

and so on

Hi @macmee

Can you please let us know the CometChat Pro SDK version that you have used? Also is it possible to share a screenshot of the same so that we can find the root cause of it. Even we are trying to replicate it at our end.

I tried both 2.0.7 and the 2.0.8beta. Anything specific I can take a photo of to help?

Hi @macmee

Okay as from the screenshot i am not sure but you can try this steps

  1. pod deintegrate
  2. pod clean
  3. pod repo update
  4. pod install

Please try this steps and then try to archive it. Do let us know if you still face this issue so that we can provide you some other solutions for it.

Hey thanks for the tip, I tried but sadly am still getting the same issue

Hi @macmee

We tried this at our end and it is working. I was able to archive the app and successfully able to validate the app for app store. Can you please tell me the Xcode version you are using? I have used Xcode version 11.3.1 and CometChat Pro SDK 2.0.7 and 2.0.8-beta1 to verify. Can you please verify the steps that you have performed while integrating CometChat Pro SDK

Hmm, My version is the same of xcode and the SDK. I followed that quick start exactly, the only thing I cannot do is use_frameworks in my podfile because it breaks my other pods.

Hi @macmee

So that is the reason of its wierd behaviour because use_framework is used to tell the cocoapods to use the framework and not as a static library. By removing the use_framework part the SDK is behaving as a static library instead of framework and it’s not linked properly It’s a geniune issue as swift doesn’t support static library so you are getting the issue. Please give us sometime to figure this out for you.

Thanks, if you guys can somehow get us a copy of the framework to work with our situation we are ready to sign a contract ASAP. We’re on a tight deadline and want to get moving fast.

Hi @macmee

We have found a workaround for which, however we don’t recommend this but as it’s a rare scenario we are suggesting you manual integration. Steps to perform manual integration is as follows:-

  1. Download the sample project from the link given below
  2. Drag and drop the CometChatPro Framework and Vendors folder from Framework folder
  3. Make sure that in target section-> General-> Frameworks, Libraries and Embedded Content all the frameworks are Embedded and sign
  4. Try and archive the app now

Download URL :- http://shorturl.at/eqLM4

Please let us know if you still face any issue while submitting the build to app store we would love to help you out.

1 Like

Hi @macmee

Is your issue resolved? Do let us know if you still have any issue we would love to help you out.

1 Like