Error: Error: Unable to resolve module `@react-native-community/async-storage` from `node_modules\@cometchat-pro\react-native-chat\CometChat.js`: @react-native-community/async-storage could not be found within the project

error: Error: Unable to resolve module @react-native-community/async-storage from node_modules\@cometchat-pro\react-native-chat\CometChat.js: @react-native-community/async-storage could not be found within the project.

I installed react-native comet chat and try to call it in index page like this below:
import { CometChat } from “@cometchat-pro/react-native-chat”;

And when I try to run with npm start. It is showing this error.

I tried to install another package as told in StackOverflow like `@react-native-community/async-storage
And I tried running this as well " npm cache clean --force"
These all didn’t help me in any manner.
A solution this would be really appreciated…

Hello @Kashyap,

Please follow the steps mentioned in the setup guide as mentioned here.

Warm Regards,

CometChat Pro
Mayur Bhandari

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.