Issue in pod installation react-native

when i try pod install i face following issue.

[!] CocoaPods could not find compatible versions for pod “react-native-cometchat-rtc”:
In Podfile:
react-native-cometchat-rtc (from ../node_modules/@cometchat-pro/react-native-calls)

Specs satisfying the react-native-cometchat-rtc (from …/node_modules/@cometchat-pro/react-native-calls) dependency were found, but they required a higher minimum deployment target.

Hello @rahul_webnexus2020,

Can you please run the following three commands. From you app root directory run cd ios and then run the following commands one after the other.

  1. pod deintegrate
  2. pod repo update
  3. pod install

Note: The commands may take time to finish execution.

Warm Regards,

CometChat Pro
Mayur Bhandari

Still getting same issue.

Hello @rahul_webnexus2020,

Can you please trying deleting the node_modules and run the npm install again.

  1. rm -rf node_modules
  2. npm cache clean --force
  3. npm install
  4. cd ios && pod install

Warm Regards,

CometChat Pro
Mayur Bhandari

Still i unable pod install, getting same error.
I also tried this on you demo app. result was same.

Hello @rahul_webnexus2020,

Can you please share the screenshot of your pod file. The issue is in your podfile the target would have been set to 10.0 Please make it to 11.0 and try once using the command in the following order

  1. pod deintegrate
  2. Delete the workspace file and podfile.lock
  3. pod install

Hope this helps you and will resolve your issue.

Warm Regards,

CometChat Pro
Mayur Bhandari

1 Like

Thanks, now it is working.

which workspace file should I delete? I only have a .xcworkspace folder in my project.

Hi @mengyzhang87

Delete the .xcworkspace that you have in your ios folder which is created after pod install. If you don’t find the project-name.xcworkspace file in iOS folder then you can just do a pod install. Do let me know if you still face issue would love to help you out

Thanks

I face the same issue.
I did

rm -rf node_modules
npm cache clean --force
npm install
cd ios 

pod deintegrate
Delete the workspace file and podfile.lock
pod install

and still face this error :

react-native-chat-app/chatApp/ios   master ● ?  pod install  :heavy_check_mark:  427  19:58:17
Detected React Native module pods for RNCMaskedView, RNGestureHandler, RNScreens, RNVectorIcons, react-native-cometchat-rtc, react-native-document-picker, react-native-image-picker, react-native-safe-area-context, and react-native-video
Analyzing dependencies
Fetching podspec for DoubleConversion from ../node_modules/react-native/third-party-podspecs/DoubleConversion.podspec
Fetching podspec for Folly from ../node_modules/react-native/third-party-podspecs/Folly.podspec
Fetching podspec for glog from ../node_modules/react-native/third-party-podspecs/glog.podspec
[!] CocoaPods could not find compatible versions for pod “react-native-cometchat-rtc”:
In Podfile:
react-native-cometchat-rtc (from ../node_modules/@cometchat-pro/react-native-calls)

Specs satisfying the react-native-cometchat-rtc (from …/node_modules/@cometchat-pro/react-native-calls) dependency were found, but they required a higher minimum deployment target.

Hello,

You need to change the deployment target to 11. In the podFile change platform :ios, 'xx.x' to platform :ios, '11.0' .

Hope this helps.

Warm Regards,

CometChat Pro
Mayur Bhandari

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.