'PiPViewCoordinator' is not a member type of 'JitsiMeet'


I have integrate ComatChatPro through pods. But when I run or build the project getting error - “PiPViewCoordinator is not a member type of JitsiMeet” and “AnimationCompletion is not a member of JitsiMeet”. I am using xcode 12.2. Can you please help me in resolving this.
Thanks in advance

Hi @Priyanka ,

Please update to our latest SDK 2.2.0 which compatible with your Xcode version. Also we have improved our calling component with our latest SDK.

Regards,
Abhishek Saralaya


Thanks for your reply.
I tried to update pods version but received this error. I had set deployment target to 14.2 but still receiving this error.

Hello @Priyanka,

It seems that you’ve entered the incorrect version in your profile. Please use the below link in your podfile.
pod 'CometChatPro','2.2.1'

Also, if you’re not able to install pod using the pod install command then use pod install --repo-update command to download it.

We suggest you to clean your project and derived data to avoid unnecessary compilation errors.
This will resolve your issue.

Thanks.

Regards,
Pushpsen R. Airekar


Thanks for your reply.
I tried to install pods with version- 2.2.1, but still it is giving same error. Can you please tell me any other solution for this.

Regards,
Priyanka

Hello @Priyanka ,

You need to set your deployment target as 11.0. Also mention platform :ios, '11.0' in your podfile.

1 Like

Thanks @pushpsen.airekar
Your solution worked.

Regards,
Priyanka

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.