Why does it need to have platform :ios on '11.0' and not '10.0'

My project is currently running on the 10.0 ios target. I’m in a Silicon-based MacBook.
Changing to 11.0 means a lot of problems in compatibility.
I need a way around on this one, is there any solution for me to use 10.0?

Hello,

Our SDK is providing support for the device above iOS 11, and at this moment there is no way to provide it for the devices for iOS 10.

We are using internal libraries which are providing support from iOS 11, so we cannot further reduce it to version 10.

Thanks.

Regards,
Pushpsen R. Airekar